New glTail version, yay! Authentication failed, Boo!

I downloaded the latest version of glTail and got an authentication failed error:

cheetara:~/Desktop will$ ./gl_tail-0.05.rb
Connecting to myserver...
/opt/local/lib/ruby/gems/1.8/gems/net-ssh-1.1.2/lib/net/ssh/session.rb:143:in `initialize': will (Net::SSH::AuthenticationFailed)
from /opt/local/lib/ruby/gems/1.8/gems/net-ssh-1.1.2/lib/net/ssh.rb:47:in `new'
from /opt/local/lib/ruby/gems/1.8/gems/net-ssh-1.1.2/lib/net/ssh.rb:47:in `start'
from ./gl_tail-0.05.rb:1034:in `init'
from ./gl_tail-0.05.rb:1025:in `each'
from ./gl_tail-0.05.rb:1025:in `init'
from ./gl_tail-0.05.rb:1070:in `initialize'
from ./gl_tail-0.05.rb:1159:in `new'
from ./gl_tail-0.05.rb:1159

I am using key based authentication to my server so I had previously set the password to:

:password => ''

This worked in the old version but to get it to work I in the new version I had to change it to this:

:password => nil

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s